user functions path not recognized ...

MATLAB interface, C API, using plugins, other interfaces

user functions path not recognized ...

Postby marchand » Tue Jul 03, 2012 10:47 pm

While I was tracking down an old bug report, I found out that the attached file, which ran fine in R2011a, does not run in R2012a. I get an error saying that it can't find the functions referenced in the file. The startup file does have these entries in it uncommented:

GMAT_FUNCTION_PATH = ROOT_PATH/userfunctions/gmat
MATLAB_FUNCTION_PATH = ROOT_PATH/userfunctions/matlab

The attached script and the modified startup file, again, worked fine for R2011a. I am uncertain as to what may have changed to cause this issue now. It would seem that the ".." in the path name is being read as a single "." I actually tried to change that to "..." to see if it would drop the first dot, but there it actually read all three dots and gave me a different error.

I'm currently running off revision #10550 because 10623 seems to be causing some issues loading plugins that otherwise compile normally and worked fine in earlier revisions.

Any ideas?
(4.83 KiB) Downloaded 169 times
Posts: 86
Joined: Tue Feb 21, 2012 2:42 pm

Re: user functions path not recognized ...

Postby jjkparker » Thu Jul 05, 2012 2:57 pm

I see this in the nightly I'm using from a few days ago, and committed GMT-2906 to track it.

One workaround here is to just comment out the FunctionPath lines. Then it'll fall back on the search path defined in the gmat_startup_file.txt, which seems to work fine (though I'm getting another error later in the script).
Joel J. K. Parker
Flight dynamics engineer, GMAT team
Posts: 617
Joined: Thu Jan 07, 2010 9:48 pm
Location: NASA Goddard Space Flight Center, Greenbelt, MD

Return to External Interfaces and Plugins

Who is online

Users browsing this forum: No registered users and 1 guest